Error 500 – Internal server error

Error 500 – Internal server error

Un problème inattendu est survenu.
Veuillez réessayer ultérieurement.

J’ai trouvé la solution chez blogityourelf, il s’agit d’une histoire de version de php. Chez 1&1 on est encore dans la version 4 de php alors que WordPress 2.7.1 et ses plugins ont besoin de php 5.

Pour corriger il suffit de rajouter ces 2 lignes au fichier .htaccess.
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Parfois la mise à jour « saute » et le fichier .htaccess retourne à sa version originale. C’est incompréhensible.

Edit N°1 : après une MAJ en WP 2.7.1 je me suis retrouvé avec une interface d’administration complètement à l’ouest et toute saccagée. Une couleur bleu ciel l’avait envahie et toutes les options étaient chamboulées. Dommage que je n’ai pas fait de capture d’écran, tout angoissé que j’étais de trouver une solution… Le changement du .htaccess a résolu le problème.


Tags : , , ,
Trackbacks Commentaires
1 2 3
Réagissez